Re: [Patch v2] x86/cpu: Add Ice Lake NNPI to Intel family

From: Dave Hansen
Date: Wed Jun 12 2019 - 10:56:06 EST


On 6/12/19 2:52 AM, Andy Shevchenko wrote:
>> #define INTEL_FAM6_ICELAKE_MOBILE 0x7E
>> +#define INTEL_FAM6_ICELAKE_NNPI 0x9D
> What "I" stands for?
>
> For me sounds like it's redundant here or something like NNP_DLI would be
> better (because somewhere we have _NP as for Network Processor).

Let's not bikeshed this too much. These things aren't used that widely
and mostly they're just used for figuring out the processor generation.
It's exceedingly rare to have something like:


if (model == INTEL_FAM6_ICELAKE_MOBILE)
foo();
else if (model == INTEL_FAM6_ICELAKE_NNPI)
bar();

where what you suggest would matter.

Preserving the ability to google "ice lake nnpi" is pretty important, so
preserving the Intel name makes a lot of sense here when possible.

Do we *HAVE* an Ice Lake network processor?