Re: [PATCH v6 01/19] kernel: Standardize vdso_datapage

From: Huw Davies
Date: Mon Jun 10 2019 - 05:39:34 EST


On Thu, May 30, 2019 at 03:15:13PM +0100, Vincenzo Frascino wrote:
> --- /dev/null
> +++ b/include/vdso/datapage.h
> @@ -0,0 +1,91 @@
> +/* SPDX-License-Identifier: GPL-2.0 */
> +#ifndef __VDSO_DATAPAGE_H
> +#define __VDSO_DATAPAGE_H
> +
> +#ifdef __KERNEL__
> +
> +#ifndef __ASSEMBLY__
> +
> +#include <linux/bits.h>
> +#include <linux/time.h>
> +#include <linux/types.h>
> +
> +#define VDSO_BASES (CLOCK_TAI + 1)
> +#define VDSO_HRES (BIT(CLOCK_REALTIME) | \
> + BIT(CLOCK_MONOTONIC) | \
> + BIT(CLOCK_BOOTTIME) | \
> + BIT(CLOCK_TAI))
> +#define VDSO_COARSE (BIT(CLOCK_REALTIME_COARSE) | \
> + BIT(CLOCK_MONOTONIC_COARSE))
> +#define VDSO_RAW (BIT(CLOCK_MONOTONIC_RAW))
> +
> +#define CS_HRES_COARSE 0
> +#define CS_RAW 1

CS_HRES_COARSE seems like a confusing name choice to me. What you
really mean is not RAW.

How about CS_ADJ to indicate that its updated by adjtime?
CS_XTIME might be another option.

Huw.