Re: [PATCH] mm: vmscan: correct nr_reclaimed for THP

From: Matthew Wilcox
Date: Fri May 10 2019 - 19:08:02 EST


On Fri, May 10, 2019 at 03:54:56PM -0700, Ira Weiny wrote:
> On Fri, May 10, 2019 at 09:36:12AM -0700, Matthew Wilcox wrote:
> > On Fri, May 10, 2019 at 10:12:40AM +0800, Huang, Ying wrote:
> > > > + nr_reclaimed += (1 << compound_order(page));
> > >
> > > How about to change this to
> > >
> > >
> > > nr_reclaimed += hpage_nr_pages(page);
> >
> > Please don't. That embeds the knowledge that we can only swap out either
> > normal pages or THP sized pages. I'm trying to make the VM capable of
> > supporting arbitrary-order pages, and this would be just one more place
> > to fix.
> >
> > I'm sympathetic to the "self documenting" argument. My current tree has
> > a patch in it:
> >
> > mm: Introduce compound_nr
> >
> > Replace 1 << compound_order(page) with compound_nr(page). Minor
> > improvements in readability.
> >
> > It goes along with this patch:
> >
> > mm: Introduce page_size()
> >
> > It's unnecessarily hard to find out the size of a potentially huge page.
> > Replace 'PAGE_SIZE << compound_order(page)' with page_size(page).
> >
> > Better suggestions on naming gratefully received. I'm more happy with
> > page_size() than I am with compound_nr(). page_nr() gives the wrong
> > impression; page_count() isn't great either.
>
> Stupid question : what does 'nr' stand for?

NumbeR. It's relatively common argot in the Linux kernel (as you can
see from the earlier example ...

> > > nr_reclaimed += hpage_nr_pages(page);

willy@bobo:~/kernel/xarray-2$ git grep -w nr mm |wc -l
388
willy@bobo:~/kernel/xarray-2$ git grep -w nr fs |wc -l
1067