Re: [PATCH][next] ath10k: Use struct_size() helper

From: Kalle Valo
Date: Tue May 07 2019 - 09:52:28 EST


"Gustavo A. R. Silva" <gustavo@xxxxxxxxxxxxxx> wrote:

> Make use of the struct_size() helper instead of an open-coded version
> in order to avoid any potential type mistakes, in particular in the
> context in which this code is being used.
>
> So, change the following form:
>
> sizeof(*rx) + (sizeof(struct htt_rx_indication_mpdu_range) * num_mpdu_ranges)
>
> to :
>
> struct_size(rx, mpdu_ranges, num_mpdu_ranges)
>
> This code was detected with the help of Coccinelle.
>
> Signed-off-by: Gustavo A. R. Silva <gustavo@xxxxxxxxxxxxxx>
> Signed-off-by: Kalle Valo <kvalo@xxxxxxxxxxxxxx>

Patch applied to ath-next branch of ath.git, thanks.

35b50e70df27 ath10k: Use struct_size() helper

--
https://patchwork.kernel.org/patch/10884271/

https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches