Re: [PATCH v3 01/10] iommu: Add helper to get minimal page size of domain

From: Lu Baolu
Date: Mon Apr 29 2019 - 20:46:43 EST


Hi Robin,

On 4/29/19 6:55 PM, Robin Murphy wrote:
On 21/04/2019 02:17, Lu Baolu wrote:
This makes it possible for other modules to know the minimal
page size supported by a domain without the knowledge of the
structure details.

Signed-off-by: Lu Baolu <baolu.lu@xxxxxxxxxxxxxxx>
---
 include/linux/iommu.h | 13 +++++++++++++
 1 file changed, 13 insertions(+)

diff --git a/include/linux/iommu.h b/include/linux/iommu.h
index a5007d035218..46679ef19b7e 100644
--- a/include/linux/iommu.h
+++ b/include/linux/iommu.h
@@ -377,6 +377,14 @@ static inline void iommu_tlb_sync(struct iommu_domain *domain)
ÂÂÂÂÂÂÂÂÂ domain->ops->iotlb_sync(domain);
 }
+static inline unsigned long domain_minimal_pgsize(struct iommu_domain *domain)
+{
+ÂÂÂ if (domain && domain->pgsize_bitmap)
+ÂÂÂÂÂÂÂ return 1 << __ffs(domain->pgsize_bitmap);

Nit: this would probably be more efficient on most architectures as:

ÂÂÂÂif (domain)
ÂÂÂÂÂÂÂ return domain->pgsize_bitmap & -domain->pgsize_bitmap;


It looks reasonable to me.


I'd also suggest s/minimal/min/ in the name, just to stop it getting too long. Otherwise, though, I like the idea, and there's at least one other place (in iommu-dma) that can make use of it straight away.

Okay, I will change the name to domain_min_pgsize().


Robin.


Best regards,
Lu Baolu

+
+ÂÂÂ return 0;
+}
+
 /* PCI device grouping function */
 extern struct iommu_group *pci_device_group(struct device *dev);
 /* Generic device grouping function */
@@ -704,6 +712,11 @@ const struct iommu_ops *iommu_ops_from_fwnode(struct fwnode_handle *fwnode)
ÂÂÂÂÂ return NULL;
 }
+static inline unsigned long domain_minimal_pgsize(struct iommu_domain *domain)
+{
+ÂÂÂ return 0;
+}
+
 #endif /* CONFIG_IOMMU_API */
 #ifdef CONFIG_IOMMU_DEBUGFS