RE: [PATCH 3/3] phy: renesas: rcar-gen3-usb2: enable/disable independent irqs

From: Yoshihiro Shimoda
Date: Tue Apr 09 2019 - 05:47:54 EST


Hi Simon-san,

> From: Simon Horman, Sent: Wednesday, April 3, 2019 6:20 PM
>
> Hi Shimoda-san,
>
> On Mon, Apr 01, 2019 at 09:01:23PM +0900, Yoshihiro Shimoda wrote:
> > Since the previous code enabled/disabled the irqs both OHCI and EHCI,
> > it is possible to cause unexpected interruptions. To avoid this,
> > this patch creates multiple phy instances from phandle and
> > enables/disables independent irqs by the instances.
> >
> > Signed-off-by: Yoshihiro Shimoda <yoshihiro.shimoda.uh@xxxxxxxxxxx>
>
> I noted a few nits below but overall this looks good to me.
>
> Reviewed-by: Simon Horman <horms+renesas@xxxxxxxxxxxx>

Thank you for your review!

<snip>
> > +#define NUM_OF_PHYS 4
> > +#define PHY_INDEX_BOTH_HC 0
> > +#define PHY_INDEX_OHCI 1
> > +#define PHY_INDEX_EHCI 2
> > +#define PHY_INDEX_HSUSB 3
>
> nit: I think the above #defines would be better expressed as an enum.

I'll modify it.

<snip>
> > +static enum usb_dr_mode rcar_gen3_get_dr_mode(struct device_node *np)
> > +{
> > + enum usb_dr_mode candidate = USB_DR_MODE_UNKNOWN, tmp;
>
> nit: I think that there could be a better name for tmp, f.e. mode
> nit: The scope of tmp could be limited to inside the for loop.

I'll modify it.

Best regards,
Yoshihiro Shimoda