RE: [PATCH 1/1] irqchip: stm32-exti: add domain translate function

From: Loic PALLARDY
Date: Fri Jan 11 2019 - 12:34:51 EST


Hi Marc,
Thanks for the review

> -----Original Message-----
> From: Marc Zyngier <marc.zyngier@xxxxxxx>
> Sent: vendredi 11 janvier 2019 16:52
> To: Loic PALLARDY <loic.pallardy@xxxxxx>; tglx@xxxxxxxxxxxxx;
> jason@xxxxxxxxxxxxxx; mcoquelin.stm32@xxxxxxxxx; Alexandre TORGUE
> <alexandre.torgue@xxxxxx>
> Cc: linux-kernel@xxxxxxxxxxxxxxx; linux-stm32@st-md-
> mailman.stormreply.com; linux-arm-kernel@xxxxxxxxxxxxxxxxxxx
> Subject: Re: [PATCH 1/1] irqchip: stm32-exti: add domain translate function
>
> On 11/01/2019 13:58, Loic Pallardy wrote:
> > Domain translate function is needed to recover irq
> > configuration parameters from DT node
> >
> > Signed-off-by: Loic Pallardy <loic.pallardy@xxxxxx>
>
> Surely this fixes something, right? Can you please add a Fixes: tag?
Yes I will add tag of patch introducing hierarchical domain

>
> > ---
> > drivers/irqchip/irq-stm32-exti.c | 18 ++++++++++++++++++
> > 1 file changed, 18 insertions(+)
> >
> > diff --git a/drivers/irqchip/irq-stm32-exti.c b/drivers/irqchip/irq-stm32-
> exti.c
> > index 6edfd4bfa169..717879028cc4 100644
> > --- a/drivers/irqchip/irq-stm32-exti.c
> > +++ b/drivers/irqchip/irq-stm32-exti.c
> > @@ -819,9 +819,27 @@ static int __init stm32_exti_init(const struct
> stm32_exti_drv_data *drv_data,
> > return ret;
> > }
> >
> > +static int stm32_exti_h_translate(struct irq_domain *d,
> > + struct irq_fwspec *fwspec,
> > + unsigned long *out_hwirq,
> > + unsigned int *out_type)
> > +{
> > + if (is_of_node(fwspec->fwnode)) {
>
> Is there any case where this wouldn't be true? i.e. an stm32 ACPI system?

You're right, no ACPI so check useless

>
> > + if (fwspec->param_count != 2)
> > + return -EINVAL;
> > +
> > + *out_hwirq = fwspec->param[0];
> > + *out_type = fwspec->param[1] & IRQ_TYPE_SENSE_MASK;
> > + return 0;
> > + }
> > +
> > + return -EINVAL;
> > +}
>
> Because otherwise, this is exactly what irq_domain_xlate_twocell() does.

Thanks for pointing me this helper. Indeed no need to duplicate code
I'll send a v2

Regards,
Loic
>
> > +
> > static const struct irq_domain_ops stm32_exti_h_domain_ops = {
> > .alloc = stm32_exti_h_domain_alloc,
> > .free = irq_domain_free_irqs_common,
> > + .translate = stm32_exti_h_translate,
> > };
> >
> > static int
> >
>
> Thanks,
>
> M.
> --
> Jazz is not dead. It just smells funny...