Re: [PATCH v14 08/11] livepatch: Remove Nop structures when unused

From: Petr Mladek
Date: Mon Dec 17 2018 - 10:54:57 EST


On Thu 2018-12-13 17:00:45, Josh Poimboeuf wrote:
> On Thu, Nov 29, 2018 at 10:44:28AM +0100, Petr Mladek wrote:
> > +static void __klp_free_funcs(struct klp_object *obj, bool free_all)
> > {
> > - struct klp_func *func;
> > + struct klp_func *func, *tmp_func;
> > +
> > + klp_for_each_func_safe(obj, func, tmp_func) {
> > + if (!free_all && !func->nop)
> > + continue;
>
> I suspect that changing 'free_all" to 'nops_only' (and inverting the
> condition) would make the code more readable.
>
> And a similar suggestion for __klp_free_objects().

I am not super happy with the negative check as well. The problem is
that in __klp_free_objects() it would look like:

if (nops_only && !obj->dynamic)
continue;

By other words, "free_all" works better with both "nops" and "dynamic".

That said, I do not mind about it. Tell me what you prefer and I'll
change it.


> > +
> > + /*
> > + * Avoid double free. It would be tricky to wait for kobject
> > + * callbacks when only NOPs are handled.
> > + */
> > + list_del(&func->node);
>
> I've read this comment several times but I still have no idea how it
> relates to the code :-)

I wrote this comment when I was lost in thoughts how to make freeing
safe. Especially I wondered whether we would need to wait until
the structures are freed.

You are right that this is needed to remove the freed nops/dynamic
structures in general.

I will remove the comment.

Best Regards,
Petr