[PATCH 14/27] kconfig: rename depends_list to comment_option_list

From: Masahiro Yamada
Date: Tue Dec 11 2018 - 06:01:44 EST


Now the comment_stmt is the only user of depends_list. Rename it to
comment_option_list

Signed-off-by: Masahiro Yamada <yamada.masahiro@xxxxxxxxxxxxx>
---

scripts/kconfig/zconf.y | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)

diff --git a/scripts/kconfig/zconf.y b/scripts/kconfig/zconf.y
index 7cc8244..7a4bc58 100644
--- a/scripts/kconfig/zconf.y
+++ b/scripts/kconfig/zconf.y
@@ -379,7 +379,12 @@ comment: T_COMMENT prompt T_EOL
printd(DEBUG_PARSE, "%s:%d:comment\n", zconf_curname(), zconf_lineno());
};

-comment_stmt: comment depends_list
+comment_stmt: comment comment_option_list
+;
+
+comment_option_list:
+ /* empty */
+ | comment_option_list depends
;

/* help option */
@@ -408,11 +413,6 @@ help: help_start T_HELPTEXT

/* depends option */

-depends_list:
- /* empty */
- | depends_list depends
-;
-
depends: T_DEPENDS T_ON expr T_EOL
{
menu_add_dep($3);
--
2.7.4