Re: [PATCH v6 0/7] tpm: retrieve digest size of unknown algorithms from TPM

From: Jarkko Sakkinen
Date: Tue Dec 04 2018 - 19:21:59 EST


On Tue, Dec 04, 2018 at 09:21:31AM +0100, Roberto Sassu wrote:
> Update
>
> This version of the patch set includes an additional patch (7/7) which
> modifies the definition of tpm_pcr_extend() and tpm2_pcr_extend(). The new
> patch has been included to facilitate the review of the changes to support
> TPM 2.0 crypto agility for reading/extending PCRs.
>
>
> Original patch set description
>
> The TPM driver currently relies on the crypto subsystem to determine the
> digest size of supported TPM algorithms. In the future, TPM vendors might
> implement new algorithms in their chips, and those algorithms might not
> be supported by the crypto subsystem.
>
> Usually, vendors provide patches for the new hardware, and likely
> the crypto subsystem will be updated before the new algorithm is
> introduced. However, old kernels might be updated later, after patches
> are included in the mainline kernel. This would leave the opportunity
> for attackers to misuse PCRs, as PCR banks with an unknown algorithm
> are not extended.
>
> This patch set provides a long term solution for this issue. If a TPM
> algorithm is not known by the crypto subsystem, the TPM driver retrieves
> the digest size from the TPM with a PCR read. All the PCR banks are
> extended, even if the algorithm is not yet supported by the crypto
> subsystem.
>
> PCR bank information (TPM algorithm ID, digest size, crypto subsystem ID)
> is stored in the tpm_chip structure and available for users of the TPM
> driver.
>
> Changelog
>
> v5:
> - rename digest_struct variable to digest
> - add _head suffix to tcg_efi_specid_event and tcg_pcr_event2
> - rename digest_size member of tpm_bank_list to extend_size
> - change type of alg_id member of tpm_bank list from u8 to u16
> - add missing semi-colon in pcrlock()
>
> v4:
> - rename active_banks to allocated_banks
> - replace kmalloc_array() with kcalloc()
> - increment nr_allocated_banks if at least one PCR in the bank is selected
> - pass multiple digests to tpm_pcr_extend()
>
> v3:
> - remove end marker change
> - replace active_banks static array with pointer to dynamic array
> - remove TPM2_ACTIVE_PCR_BANKS
>
> v2:
> - change the end marker of the active_banks array
> - check digest size from output of PCR read command
> - remove count parameter from tpm_pcr_read() and tpm2_pcr_read()
>
> v1:
> - modify definition of tpm_pcr_read()
> - move hash algorithms and definition of tpm2_digest to include/linux/tpm.h
>
> Roberto Sassu (7):
> tpm: dynamically allocate the allocated_banks array
> tpm: add _head suffix to tcg_efi_specid_event and tcg_pcr_event2
> tpm: rename and export tpm2_digest and tpm2_algorithms
> tpm: modify tpm_pcr_read() definition to pass a TPM hash algorithm
> tpm: retrieve digest size of unknown algorithms with PCR read
> tpm: ensure that the output of PCR read contains the correct digest
> size
> tpm: pass an array of tpm_bank_list structures to tpm_pcr_extend()
>
> drivers/char/tpm/eventlog/tpm2.c | 12 +--
> drivers/char/tpm/tpm-chip.c | 1 +
> drivers/char/tpm/tpm-interface.c | 36 +++----
> drivers/char/tpm/tpm.h | 23 ++---
> drivers/char/tpm/tpm1-cmd.c | 26 ++++-
> drivers/char/tpm/tpm2-cmd.c | 154 +++++++++++++++++++++-------
> include/linux/tpm.h | 43 +++++++-
> include/linux/tpm_eventlog.h | 19 +---
> security/integrity/ima/ima_crypto.c | 10 +-
> security/integrity/ima/ima_queue.c | 5 +-
> security/keys/trusted.c | 5 +-
> 11 files changed, 220 insertions(+), 114 deletions(-)
>
> --
> 2.17.1
>

Some generic stuff I noticed:

* Use SHA1_DIGEST_SIZE, not TPM_DIGEST_SIZE. The latter is just
uninforming constant that we want to get rid off.

/Jarkko