Re: [PATCH 6/5] x86/fault: Clean up the page fault oops decoder a bit

From: Sean Christopherson
Date: Tue Dec 04 2018 - 14:52:42 EST


On Tue, Dec 04, 2018 at 11:47:10AM -0800, Andy Lutomirski wrote:
> On Tue, Dec 4, 2018 at 11:34 AM Sean Christopherson
> <sean.j.christopherson@xxxxxxxxx> wrote:
> >
> > On Tue, Dec 04, 2018 at 11:22:25AM -0800, Andy Lutomirski wrote:
> > > On Tue, Nov 27, 2018 at 7:32 AM Sean Christopherson
> > > <sean.j.christopherson@xxxxxxxxx> wrote:
> > > > diff --git a/arch/x86/mm/fault.c b/arch/x86/mm/fault.c
> > > > index 2ff25ad33233..510e263c256b 100644
> > > > --- a/arch/x86/mm/fault.c
> > > > +++ b/arch/x86/mm/fault.c
> > > > @@ -660,8 +660,10 @@ show_fault_oops(struct pt_regs *regs, unsigned long error_code, unsigned long ad
> > > > err_str_append(error_code, err_txt, X86_PF_RSVD, "[RSVD]" );
> > > > err_str_append(error_code, err_txt, X86_PF_INSTR, "[INSTR]");
> > > > err_str_append(error_code, err_txt, X86_PF_PK, "[PK]" );
> > > > -
> > > > - pr_alert("#PF error: %s\n", error_code ? err_txt : "[normal kernel read fault]");
> > > > + err_str_append(~error_code, err_txt, X86_PF_USER, "[KERNEL]");
> > > > + err_str_append(~error_code, err_txt, X86_PF_WRITE | X86_PF_INSTR,
> > > > + "[READ]");
> > > > + pr_alert("#PF error code: %s\n", err_txt);
> > > >
> > >
> > > Seems generally nice, but I would suggest making the bit-not-set name
> > > be another parameter to err_str_append(). I'm also slightly uneasy
> > > about making "KERNEL" look like a bit, but I guess it doesn't bother
> > > me too much.
> >
> > What about "SUPERVISOR" instead of "KERNEL"? It'd be consistent with
> > the SDM and hopefully less likely to be misconstrued as something else.
>
> Or even just [!USER], perhaps.

I thought about that too, but the pedant in me didn't like the inconsistency
of doing "READ" instead of "[!WRITE] [!INSTR]", and IMO "READ" is a lot more
readable (no pun intended). I also like having completely different text,
makes it harder to miss a single "!" and go down the wrong path.