Re: [RFT PATCH v1 3/4] cpu-topology: Move cpu topology code to common code.

From: Atish Patra
Date: Mon Dec 03 2018 - 12:31:22 EST


On 12/3/18 9:16 AM, Sudeep Holla wrote:
On Thu, Nov 29, 2018 at 03:28:19PM -0800, Atish Patra wrote:
Both RISC-V & ARM64 are using cpu-map device tree to describe
their cpu topology. It's better to move the relevant code to
a common place instead of duplicate code.

Signed-off-by: Atish Patra <atish.patra@xxxxxxx>
---
arch/arm64/include/asm/topology.h | 22 ---
arch/arm64/kernel/topology.c | 303 +-------------------------------------
drivers/base/arch_topology.c | 294 ++++++++++++++++++++++++++++++++++++
include/linux/arch_topology.h | 26 ++++
include/linux/topology.h | 1 +
5 files changed, 325 insertions(+), 321 deletions(-)

From a quick look and diffstat, it looks like a simple move. However
I would like to throw this at 0-day bot to test various build configurations
so that it's not breaking anything. I can push to a branch in my git
@kernel.org but not sure on the build coverage. Anyways will update
with any results on build and testing on my side ASAP.

Thanks. It definitely need to rigorous build testing for different configurations.

What is the best practice to trigger expansive build tests?
linux-kernel@xxxxxxxxxxxxxxx is in CC.

Regards,
Atish
--
Regards,
Sudeep