Re: [PATCH v18 1/5] iommu/arm-smmu: Add pm_runtime/sleep ops

From: Robin Murphy
Date: Wed Nov 28 2018 - 11:36:44 EST


On 28/11/2018 16:24, Stephen Boyd wrote:
Quoting Vivek Gautam (2018-11-27 02:11:41)
@@ -1966,6 +1970,23 @@ static const struct of_device_id arm_smmu_of_match[] = {
};
MODULE_DEVICE_TABLE(of, arm_smmu_of_match);
+static void arm_smmu_fill_clk_data(struct arm_smmu_device *smmu,
+ const char * const *clks)
+{
+ int i;
+
+ if (smmu->num_clks < 1)
+ return;
+
+ smmu->clks = devm_kcalloc(smmu->dev, smmu->num_clks,
+ sizeof(*smmu->clks), GFP_KERNEL);
+ if (!smmu->clks)
+ return;
+
+ for (i = 0; i < smmu->num_clks; i++)
+ smmu->clks[i].id = clks[i];

Is this clk_bulk_get_all()?

Ooh, did that finally get merged while we weren't looking? Great!

Much as I don't want to drag this series out to a v19, it *would* be neat if we no longer need to open-code that bit...

Robin.