Re: [PATCH] block: respect virtual boundary mask in bvecs

From: Sagi Grimberg
Date: Tue Nov 06 2018 - 22:31:00 EST



How about changing that expression into the following to make it easier
for the compiler to optimize this code?

(offset | (bprv->bv_offset + bprv->bv_len)) & queue_virt_boundary(q)

Uhm I have to admit I'm not really able to parse the above expression.
Sure GCC will do it but I think it's less readable (at least for me).
Let's see what other's think.

I personally not a huge fan of decoding complicated expressions. But if
others are fine with it then I am too...