Re: [PATCH v2] bit_spinlock: introduce smp_cond_load_relaxed

From: Gao Xiang
Date: Mon Nov 05 2018 - 20:45:58 EST


Hi Will,

On 2018/11/6 6:49, Will Deacon wrote:
> Hi Gao,
>
> On Tue, Oct 30, 2018 at 02:04:41PM +0800, Gao Xiang wrote:
>> It is better to use wrapped smp_cond_load_relaxed
>> instead of open-coded busy waiting for bit_spinlock.
>>
>> Signed-off-by: Gao Xiang <gaoxiang25@xxxxxxxxxx>
>> ---
>>
>> change log v2:
>> - fix the incorrect expression !(VAL >> (bitnum & (BITS_PER_LONG-1)))
>> - the test result is described in the following reply.
> Please include the results in the commit message, so that this change is
> justified.

Will add in the next version...

>
> This appears to introduce a bunch of overhead for the uncontended fastpath.
> How about the much-simpler-but-completely-untested (tm) patch below?

Actually I thought to do like the following (much simpler indeed) at first...

But the current implementation of smp_cond_load_relaxed will do a judgement immediately
which seems unnecessary (right after the test_and_set_bit_lock rather than after
__cmpwait_relaxed...)
for (;;) { \
VAL = READ_ONCE(*__PTR); \
if (cond_expr) \
break; \
__cmpwait_relaxed(__PTR, VAL); \
} \

p.s. I have no idea the original uncontended fastpath really works effectively...
some idea about this? Thanks in advance...


Thanks,
Gao Xiang


>
> Will
>
> --->8
>
> diff --git a/include/asm-generic/bitops/lock.h b/include/asm-generic/bitops/lock.h
> index 3ae021368f48..9de8d3544630 100644
> --- a/include/asm-generic/bitops/lock.h
> +++ b/include/asm-generic/bitops/lock.h
> @@ -6,6 +6,15 @@
> #include <linux/compiler.h>
> #include <asm/barrier.h>
>
> +static inline void spin_until_bit_unlock(unsigned int nr,
> + volatile unsigned long *p)
> +{
> + unsigned long mask = BIT_MASK(bitnum);
> +
> + p += BIT_WORD(nr);
> + smp_cond_load_relaxed(p, VAL & mask);
> +}
> +
> /**
> * test_and_set_bit_lock - Set a bit and return its old value, for lock
> * @nr: Bit to set
> diff --git a/include/linux/bit_spinlock.h b/include/linux/bit_spinlock.h
> index bbc4730a6505..d711c62e718c 100644
> --- a/include/linux/bit_spinlock.h
> +++ b/include/linux/bit_spinlock.h
> @@ -26,9 +26,7 @@ static inline void bit_spin_lock(int bitnum, unsigned long *addr)
> #if defined(CONFIG_SMP) || defined(CONFIG_DEBUG_SPINLOCK)
> while (unlikely(test_and_set_bit_lock(bitnum, addr))) {
> preempt_enable();
> - do {
> - cpu_relax();
> - } while (test_bit(bitnum, addr));
> + spin_until_bit_unlock(bitnum, addr);
> preempt_disable();
> }
> #endif