[PATCH 0/8] pstore improvements (pstore-next)

From: Kees Cook
Date: Thu Nov 01 2018 - 19:52:32 EST


This is a posting of several patches I've been working on to improve
pstore. Most of it is better comments, output, and naming, but one
bug fix stands out to fix head-truncationg of compressed records.
Details in the individual patches. Review appreciated! :)

-Kees

Kees Cook (8):
pstore/ram: Standardize module name in ramoops
pstore: Do not use crash buffer for decompression
pstore/ram: Report backend assignments with finer granularity
pstore/ram: Add kern-doc for struct persistent_ram_zone
pstore: Improve and update some comments and status output
pstore: Replace open-coded << with BIT()
pstore: Remove needless lock during console writes
pstore/ram: Correctly calculate usable PRZ bytes

fs/pstore/platform.c | 92 ++++++++++++++------------------------
fs/pstore/ram.c | 19 ++++----
fs/pstore/ram_core.c | 25 +++++++++--
include/linux/pstore.h | 15 ++++---
include/linux/pstore_ram.h | 46 +++++++++++++++++--
5 files changed, 116 insertions(+), 81 deletions(-)

--
2.17.1