Re: [PATCH] mtd: rawnand: jz4780: use struct_size() in devm_kzalloc()

From: Kees Cook
Date: Thu Aug 23 2018 - 17:50:55 EST


On Thu, Aug 23, 2018 at 12:33 PM, Gustavo A. R. Silva
<gustavo@xxxxxxxxxxxxxx> wrote:
> One of the more common cases of allocation size calculations is finding
> the size of a structure that has a zero-sized array at the end, along
> with memory for some number of elements for that array. For example:
>
> struct foo {
> int stuff;
> void *entry[];
> };
>
> instance = devm_kzalloc(dev, sizeof(struct foo) + sizeof(void *) * count, GFP_KERNEL);
>
> Instead of leaving these open-coded and prone to type mistakes, we can
> now use the new struct_size() helper:
>
> instance = devm_kzalloc(dev, struct_size(instance, entry, count), GFP_KERNEL);
>
> Signed-off-by: Gustavo A. R. Silva <gustavo@xxxxxxxxxxxxxx>

Reviewed-by: Kees Cook <keescook@xxxxxxxxxxxx>

-Kees

> ---
> drivers/mtd/nand/raw/jz4780_nand.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/mtd/nand/raw/jz4780_nand.c b/drivers/mtd/nand/raw/jz4780_nand.c
> index db4fa60..ac62395 100644
> --- a/drivers/mtd/nand/raw/jz4780_nand.c
> +++ b/drivers/mtd/nand/raw/jz4780_nand.c
> @@ -352,7 +352,7 @@ static int jz4780_nand_probe(struct platform_device *pdev)
> return -ENODEV;
> }
>
> - nfc = devm_kzalloc(dev, sizeof(*nfc) + (sizeof(nfc->cs[0]) * num_banks), GFP_KERNEL);
> + nfc = devm_kzalloc(dev, struct_size(nfc, cs, num_banks), GFP_KERNEL);
> if (!nfc)
> return -ENOMEM;
>
> --
> 2.7.4
>



--
Kees Cook
Pixel Security