Re: [PATCH] bpf: remove unnecessary condition in bpf_check()

From: Alexei Starovoitov
Date: Mon Jul 09 2018 - 19:01:13 EST


On Mon, Jul 09, 2018 at 01:48:37PM +0200, Tobias Tefke wrote:
> In the label skip_full_check the function sanitize_dead_code()
> is being called if the return value equals zero.
> After that call there is another condition checking
> if the return value equals zero.
> If this condition evaluates to true,
> check_max_stack_depth() is being called.
> However, sanitize_dead_code() has no return value.
> Therefore the return value of bpf_check() is still the same
> and the condition can be removed.
>
> Signed-off-by: Tobias Tefke <tobias.tefke@xxxxxxxxxxxx>
> ---
> kernel/bpf/verifier.c | 5 ++---
> 1 file changed, 2 insertions(+), 3 deletions(-)
>
> diff --git a/kernel/bpf/verifier.c b/kernel/bpf/verifier.c
> index 9e2bf834f13a..b022d0a85427 100644
> --- a/kernel/bpf/verifier.c
> +++ b/kernel/bpf/verifier.c
> @@ -5935,11 +5935,10 @@ int bpf_check(struct bpf_prog **prog, union bpf_attr *attr)
> while (!pop_stack(env, NULL, NULL));
> free_states(env);
>
> - if (ret == 0)
> + if (ret == 0) {
> sanitize_dead_code(env);
> -
> - if (ret == 0)
> ret = check_max_stack_depth(env);
> + }

Technically the patch is correct, but I think it would make
the code harder to read. I prefer to keep it as-is.