Re: [PATCH 01/11] i2c: add helpers for locking the I2C segment

From: Wolfram Sang
Date: Mon Jun 18 2018 - 07:06:09 EST



> +static inline void
> +i2c_lock_segment(struct i2c_adapter *adapter)
> +{
> + i2c_lock_bus(adapter, I2C_LOCK_SEGMENT);
> +}
> +
> +static inline int
> +i2c_trylock_segment(struct i2c_adapter *adapter)
> +{
> + return i2c_trylock_bus(adapter, I2C_LOCK_SEGMENT);
> +}
> +
> +static inline void
> +i2c_unlock_segment(struct i2c_adapter *adapter)
> +{
> + i2c_unlock_bus(adapter, I2C_LOCK_SEGMENT);
> +}

I wonder if i2c_lock_segment() and i2c_lock_root_adapter() are really
more readable and convenient than i2c_lock_bus() with the flag. I think
the flags have speaking names, too.

Is that an idea to remove these functions altogether and start using
i2c_lock_bus()?

Attachment: signature.asc
Description: PGP signature