Re: [PATCH v2 01/21] usb: phy: use match_string() helper

From: Sergei Shtylyov
Date: Thu May 31 2018 - 14:56:16 EST


On 05/31/2018 09:47 PM, Andy Shevchenko wrote:

>>> - donot rename err to ret - per Andy
>>
>> Hm...
>
>>> - int err, i;
>
>>> + err = match_string(usbphy_modes, ARRAY_SIZE(usbphy_modes), phy_type);
>>> + if (err < 0)
>>
>> This is one of the few cases when 'err' is not the best name for such a
>> variable. I'd prefer to see something like 'match' or even 'rc' or 'ret'... :-)
>
> Then leaving i would make it?

Yes. :-)

> I'm okay with either which just not renames err, b/c it's used with
> something else in this function.

Looking at it again, 'err' seems equally bad for the result of
of_property_read_string()... unless the check there is changed to just *if* (err) --
this function never returns positive values, 0 means success, others mean error.

MBR, Sergei