[PATCH v3 3/5] arm64: dts: rockchip: Add GPIO_MUTE pin support to rk3328

From: djw
Date: Wed May 30 2018 - 23:28:53 EST


From: Levin Du <djw@xxxxxxxxxxxxx>

Adding a new gpio controller named "gpio_mute" to rk3328, providing
access to the GPIO_MUTE pin, which is manupulated by the GRF_SOC_CON10
register.

The GPIO_MUTE pin is referred to as <&gpio_mute 0>.

Signed-off-by: Levin Du <djw@xxxxxxxxxxxxx>

---

Changes in v3:
- Use dedicated "rockchip,rk3328-gpio-mute" driver

Changes in v2:
- Rename gpio_syscon10 to gpio_mute in rk3328.dtsi

Changes in v1:
- Split from V0 and add to rk3328.dtsi for general use.

arch/arm64/boot/dts/rockchip/rk3328.dtsi | 7 +++++++
1 file changed, 7 insertions(+)

diff --git a/arch/arm64/boot/dts/rockchip/rk3328.dtsi b/arch/arm64/boot/dts/rockchip/rk3328.dtsi
index be2bfbc..2ee0fa3 100644
--- a/arch/arm64/boot/dts/rockchip/rk3328.dtsi
+++ b/arch/arm64/boot/dts/rockchip/rk3328.dtsi
@@ -309,6 +309,13 @@
mode-loader = <BOOT_BL_DOWNLOAD>;
};

+ /* Use <&gpio_mute 0> to refer to GPIO_MUTE pin */
+ gpio_mute: gpio-mute {
+ compatible = "rockchip,rk3328-gpio-mute";
+ gpio-controller;
+ #gpio-cells = <2>;
+ status = "disabled";
+ };
};

uart0: serial@ff110000 {
--
2.7.4