Re: [PATCH 5/9] x86/dumpstack: Improve opcodes dumping in the Code: section

From: Linus Torvalds
Date: Thu Mar 08 2018 - 13:00:17 EST


On Thu, Mar 8, 2018 at 2:16 AM, Borislav Petkov <bp@xxxxxxxxx> wrote:
> +#define OPCODE_BUFSIZE 64
> + unsigned int code_prologue = OPCODE_BUFSIZE * 43 / OPCODE_BUFSIZE;

Heh.

That's a very odd way of writing "43".

Honestly, the "43" is just "two thirds" rounded to closest, and it's
not important anyway, so I think you should just write it as

unsigned int code_prologue = OPCODE_BUFSIZE * 2 / 3;

and never mind that it will now be 42.

42 is obviously the right answer anyway, which makes me think we got
it wrong earlier.

Linus