Re: [PATCH v3] ACPI: Parse entire table as a term_list for Dell XPS 9570 and Precision M5530

From: Rafael J. Wysocki
Date: Sun Feb 04 2018 - 03:27:36 EST


On Wed, Jan 31, 2018 at 5:56 AM, Kai-Heng Feng
<kai.heng.feng@xxxxxxxxxxxxx> wrote:
> The i2c touchpad on Dell XPS 9570 and Precision M5530 doesn't work out
> of box.
>
> The touchpad relies on its _INI method to update its _HID value from
> XXXX0000 to SYNA2393.
> Also, the _STA relies on value of I2CN to report correct status.
>
> Set acpi_gbl_parse_table_as_term_list so the value of I2CN can be
> correctly set up, and _INI can get run. The ACPI table in this machine
> is designed to get parsed this way.
>
> Also, change the quirk table to a more generic name.
>
> Bugzilla: https://bugzilla.kernel.org/show_bug.cgi?id=198515
> Cc: Mario Limonciello <mario.limonciello@xxxxxxxx>
> Signed-off-by: Kai-Heng Feng <kai.heng.feng@xxxxxxxxxxxxx>
> ---
> v3: Put the function under right #ifdef, comment adjustment
>
> v2: Andy's suggestion, merge to a single quirk table.
>
> drivers/acpi/bus.c | 40 +++++++++++++++++++++++++++++++++-------
> 1 file changed, 33 insertions(+), 7 deletions(-)
>
> diff --git a/drivers/acpi/bus.c b/drivers/acpi/bus.c
> index 4d0979e02a28..7cb18bc2b59a 100644
> --- a/drivers/acpi/bus.c
> +++ b/drivers/acpi/bus.c
> @@ -66,10 +66,39 @@ static int set_copy_dsdt(const struct dmi_system_id *id)
> return 0;
> }
> #endif
> +static int set_gbl_term_list(const struct dmi_system_id *id)
> +{
> + pr_notice("%s detected - parse the entire table as a term_list\n",
> + id->ident);

This is not a useful message for a user (who may not know what
trem_list is). Care to change it to something more useful, or even
drop it?