Re: [PATCH 2/2] extcon: add optional debounce-timeout-ms attribute

From: Chanwoo Choi
Date: Mon Oct 16 2017 - 19:20:12 EST


Hi,

On 2017ë 10ì 16ì 16:34, Raveendra Padasalagi wrote:
> Add changes to capture optional dt attribute "debounce-timeout-ms"
> provided in extcon node and used the same value if provided otherwise
> default value of 20ms is used for id and vbus gpios debounce time.
>
> Signed-off-by: Raveendra Padasalagi <raveendra.padasalagi@xxxxxxxxxxxx>
> Reviewed-by: Ray Jui <ray.jui@xxxxxxxxxxxx>
> Reviewed-by: Srinath Mannam <srinath.mannam@xxxxxxxxxxxx>
> ---
> drivers/extcon/extcon-usb-gpio.c | 13 ++++++++++---
> 1 file changed, 10 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/extcon/extcon-usb-gpio.c b/drivers/extcon/extcon-usb-gpio.c
> index 9c925b0..090f65f 100644
> --- a/drivers/extcon/extcon-usb-gpio.c
> +++ b/drivers/extcon/extcon-usb-gpio.c
> @@ -41,6 +41,7 @@ struct usb_extcon_info {
>
> unsigned long debounce_jiffies;
> struct delayed_work wq_detcable;
> + unsigned int gpio_debounce_timeout_ms;

You better to use the "debounce_usecs" name
because the unit of debounce time is usec.

> };
>
> static const unsigned int usb_extcon_cable[] = {
> @@ -133,6 +134,11 @@ static int usb_extcon_probe(struct platform_device *pdev)
> if (IS_ERR(info->vbus_gpiod))
> return PTR_ERR(info->vbus_gpiod);
>
> + ret = of_property_read_u32(np, "debounce-timeout-ms",
> + &info->gpio_debounce_timeout_ms);

I prefer to use the 'input-debounce' property name
Because the pinctrl-bindings.txt[1] gives the guide
for the generic name of debounce.
[1] Documentation/devicetree/bindings/pinctrl/pinctrl-bindings.txt
- "debounce-timeout-ms" -> "input-debounce"

> + if (ret)
> + info->gpio_debounce_timeout_ms = USB_GPIO_DEBOUNCE_MS;
> +
> info->edev = devm_extcon_dev_allocate(dev, usb_extcon_cable);
> if (IS_ERR(info->edev)) {
> dev_err(dev, "failed to allocate extcon device\n");
> @@ -147,13 +153,14 @@ static int usb_extcon_probe(struct platform_device *pdev)
>
> if (info->id_gpiod)
> ret = gpiod_set_debounce(info->id_gpiod,
> - USB_GPIO_DEBOUNCE_MS * 1000);
> + info->gpio_debounce_timeout_ms * 1000);
> if (!ret && info->vbus_gpiod)
> ret = gpiod_set_debounce(info->vbus_gpiod,
> - USB_GPIO_DEBOUNCE_MS * 1000);
> + info->gpio_debounce_timeout_ms * 1000);
>
> if (ret < 0)
> - info->debounce_jiffies = msecs_to_jiffies(USB_GPIO_DEBOUNCE_MS);
> + info->debounce_jiffies = msecs_to_jiffies(
> + info->gpio_debounce_timeout_ms);
>
> INIT_DELAYED_WORK(&info->wq_detcable, usb_extcon_detect_cable);
>
>

--
Best Regards,
Chanwoo Choi
Samsung Electronics