Re: [PATCH] x86: use register variable to get stack pointer value

From: Andy Lutomirski
Date: Fri Sep 29 2017 - 14:38:25 EST


On Fri, Sep 29, 2017 at 8:38 AM, Josh Poimboeuf <jpoimboe@xxxxxxxxxx> wrote:
> On Fri, Sep 29, 2017 at 05:15:36PM +0300, Andrey Ryabinin wrote:
>> Currently we use current_stack_pointer() function to get the value
>> of the stack pointer register. Since commit f5caf621ee35
>> ("x86/asm: Fix inline asm call constraints for Clang") we have stack
>> register variable declared. It can be used instead of current_stack_pointer()
>> function which allows to optimize away some excessive "mov %rsp, %<dst>"
>> instructions:
>>
>> -mov %rsp,%rdx
>> -sub %rdx,%rax
>> -cmp $0x3fff,%rax
>> -ja ffffffff810722fd <ist_begin_non_atomic+0x2d>
>>
>> +sub %rsp,%rax
>> +cmp $0x3fff,%rax
>> +ja ffffffff810722fa <ist_begin_non_atomic+0x2a>
>>
>> Remove current_stack_pointer(), rename __asm_call_sp to current_stack_pointer
>> and use it instead of removed function.
>>
>> Signed-off-by: Andrey Ryabinin <aryabinin@xxxxxxxxxxxxx>
>
> Reviewed-by: Josh Poimboeuf <jpoimboe@xxxxxxxxxx>


Ok with me. As an alternative, you could leave it as
current_stack_pointer(), but either way is fine.