Re: [PATCH v8 13/28] x86/insn-eval: Add utility function to get segment descriptor

From: Neri, Ricardo
Date: Wed Sep 27 2017 - 13:39:40 EST


On Tue, 2017-09-26 at 20:05 +0200, Borislav Petkov wrote:
> On Fri, Aug 18, 2017 at 05:27:54PM -0700, Ricardo Neri wrote:
> >
> > The segment descriptor contains information that is relevant to how
> > linear
> > addresses need to be computed. It contains the default size of
> > addresses
> > as well as the base address of the segment. Thus, given a segment
> > selector, we ought look at segment descriptor to correctly
> > calculate the
> ÂÂÂÂ^
> ÂÂÂÂto

I will correct this syntax error.
>
> >
> > linear address.
> >
> > In protected mode, the segment selector might indicate a segment
> > descriptor from either the global descriptor table or a local
> > descriptor
> > table. Both cases are considered in this function.
> >
> > This function is a prerequisite for functions in subsequent commits
> > that
> > will obtain the aforementioned attributes of the segment
> > descriptor.
> >
> > Cc: Dave Hansen <dave.hansen@xxxxxxxxxxxxxxx>
> > Cc: Adam Buchbinder <adam.buchbinder@xxxxxxxxx>
> > Cc: Colin Ian King <colin.king@xxxxxxxxxxxxx>
> > Cc: Lorenzo Stoakes <lstoakes@xxxxxxxxx>
> > Cc: Qiaowei Ren <qiaowei.ren@xxxxxxxxx>
> > Cc: Arnaldo Carvalho de Melo <acme@xxxxxxxxxx>
> > Cc: Masami Hiramatsu <mhiramat@xxxxxxxxxx>
> > Cc: Adrian Hunter <adrian.hunter@xxxxxxxxx>
> > Cc: Kees Cook <keescook@xxxxxxxxxxxx>
> > Cc: Thomas Garnier <thgarnie@xxxxxxxxxx>
> > Cc: Peter Zijlstra <peterz@xxxxxxxxxxxxx>
> > Cc: Borislav Petkov <bp@xxxxxxx>
> > Cc: Dmitry Vyukov <dvyukov@xxxxxxxxxx>
> > Cc: Ravi V. Shankar <ravi.v.shankar@xxxxxxxxx>
> > Cc: x86@xxxxxxxxxx
> > Signed-off-by: Ricardo Neri <ricardo.neri-calderon@xxxxxxxxxxxxxxx>
> > ---
> > Âarch/x86/lib/insn-eval.c | 55
> > ++++++++++++++++++++++++++++++++++++++++++++++++
> > Â1 file changed, 55 insertions(+)
> >
> > diff --git a/arch/x86/lib/insn-eval.c b/arch/x86/lib/insn-eval.c
> > index 86f58ce6c302..9cf2c49afc15 100644
> > --- a/arch/x86/lib/insn-eval.c
> > +++ b/arch/x86/lib/insn-eval.c
> > @@ -6,9 +6,13 @@
> > Â#include <linux/kernel.h>
> > Â#include <linux/string.h>
> > Â#include <linux/ratelimit.h>
> > +#include <linux/mmu_context.h>
> > +#include <asm/desc_defs.h>
> > +#include <asm/desc.h>
> > Â#include <asm/inat.h>
> > Â#include <asm/insn.h>
> > Â#include <asm/insn-eval.h>
> > +#include <asm/ldt.h>
> > Â#include <asm/vm86.h>
> > Â
> > Âenum reg_type {
> > @@ -402,6 +406,57 @@ static int get_reg_offset(struct insn *insn,
> > struct pt_regs *regs,
> > Â}
> > Â
> > Â/**
> > + * get_desc() - Obtain address of segment descriptor
> ÂÂÂGet segment descriptor.
>
> >
> > + * @sel: Segment selector
> > + *
> > + * Given a segment selector, obtain a pointer to the segment
> > descriptor.
> > + * Both global and local descriptor tables are supported.
> > + *
> > + * Return: pointer to segment descriptor on success. NULL on
> > error.
> > + */
> > +static struct desc_struct *get_desc(unsigned short sel)
> I've simplified this function to be more readable, here's a diff
> ontop.
>
> More specifically, if you flip the logic and move @desc inside the
> if,
> you don't need to have mutex_unlock() twice in there.
>
> And having a local @ldt ptr makes the selector check more readable.
>
> ---
> diff --git a/arch/x86/lib/insn-eval.c b/arch/x86/lib/insn-eval.c
> index 9cf2c49afc15..48af787cb160 100644
> --- a/arch/x86/lib/insn-eval.c
> +++ b/arch/x86/lib/insn-eval.c
> @@ -417,24 +417,24 @@ static int get_reg_offset(struct insn *insn,
> struct pt_regs *regs,
> Âstatic struct desc_struct *get_desc(unsigned short sel)
> Â{
> Â struct desc_ptr gdt_desc = {0, 0};
> - struct desc_struct *desc = NULL;
> Â unsigned long desc_base;
> Â
> Â#ifdef CONFIG_MODIFY_LDT_SYSCALL
> Â if ((sel & SEGMENT_TI_MASK) == SEGMENT_LDT) {
> + struct desc_struct *desc = NULL;
> + struct ldt_struct *ldt;
> +
> Â /* Bits [15:3] contain the index of the desired
> entry. */
> Â sel >>= 3;
> Â
> Â mutex_lock(&current->active_mm->context.lock);
> - /* The size of the LDT refers to the number of
> entries. */
> - if (!current->active_mm->context.ldt ||
> - ÂÂÂÂsel >= current->active_mm->context.ldt-
> >nr_entries) {
> - mutex_unlock(&current->active_mm-
> >context.lock);
> - return NULL;
> - }
> Â
> - desc = &current->active_mm->context.ldt-
> >entries[sel];
> + ldt = current->active_mm->context.ldt;
> + if (ldt && sel < ldt->nr_entries)
> + desc = &ldt->entries[sel];
> +
> Â mutex_unlock(&current->active_mm->context.lock);
> +
> Â return desc;
> Â }
> Â#endif
> @@ -452,8 +452,7 @@ static struct desc_struct *get_desc(unsigned
> short sel)
> Â if (desc_base > gdt_desc.size)
> Â return NULL;
> Â
> - desc = (struct desc_struct *)(gdt_desc.address + desc_base);
> - return desc;
> + return (struct desc_struct *)(gdt_desc.address + desc_base);

I have incorporated these changes in my code.

Thanks and BR,
Ricardo