Re: [PATCH][v2] PM / Hibernate: Feed the wathdog when creating snapshot

From: Michal Hocko
Date: Wed Aug 23 2017 - 03:15:00 EST


On Wed 23-08-17 11:44:39, Chen Yu wrote:
> On Tue, Aug 22, 2017 at 02:55:39PM +0200, Rafael J. Wysocki wrote:
> > On Tuesday, August 22, 2017 5:20:02 AM CEST Chen Yu wrote:
[...]
> > > void mark_free_pages(struct zone *zone)
> > > {
> > > - unsigned long pfn, max_zone_pfn;
> > > + unsigned long pfn, max_zone_pfn, page_num = 0;
> >
> > + unsigned long pfn, max_zone_pfn, page_count = WD_PAGE_COUNT;
> >
> > > unsigned long flags;
> > > unsigned int order, t;
> > > struct page *page;
> > > @@ -2552,6 +2559,9 @@ void mark_free_pages(struct zone *zone)
> > > if (pfn_valid(pfn)) {
> > > page = pfn_to_page(pfn);
> > >
> > > + if (!((page_num++) % WD_INTERVAL_PAGE))
> > > + touch_nmi_watchdog();
> > > +
> >
> > ->
> >
> > if (!--page_count) {
> > touch_nmi_watchdog();
> > page_count = WD_PAGE_COUNT;
> > }
> >
> I guess this is to avoid the possible overflow if the page number is too large?

Even if the page_count overflown it wouldn't be a problem because of the
unsigned arithmetic. To be honest I find yours modulo based approach
easier to follow. Maybe it even compiles to a better code but I haven't
checked. Anyway one way or the other both ways are reasonable so
whatever Rafael (as the maintainer) prefers.

--
Michal Hocko
SUSE Labs