Re: [PATCH] irq_work: improve the flag definitions

From: Bartosz Golaszewski
Date: Mon Aug 14 2017 - 13:12:24 EST


2017-08-14 14:19 GMT+02:00 Andy Shevchenko <andy.shevchenko@xxxxxxxxx>:
> On Mon, Aug 14, 2017 at 2:56 PM, Bartosz Golaszewski <brgl@xxxxxxxx> wrote:
>> IRQ_WORK_FLAGS is defined simply to 3UL. This is confusing as it
>> says nothing about its purpose. Define IRQ_WORK_FLAGS as a bitwise
>> OR of IRQ_WORK_PENDING and IRQ_WORK_BUSY.
>>
>> While we're at it: use the BIT() macro for all flags.
>
>> +#define IRQ_WORK_PENDING BIT(0)
>> +#define IRQ_WORK_BUSY BIT(1)
>> +#define IRQ_WORK_FLAGS (IRQ_WORK_PENDING | IRQ_WORK_BUSY)
>
> I dunno which style is preferred, though I would go with simple
> GENMASK() here, as all definitions right on left :-)
>
> Parameters of GENMASK will show last-first entries and can be easily decoded.
> Although there are only two for now.
>

Which is a good enough reason to not over-complicate things and just
use an easy to decipher bitwise OR. ;)

Thanks,
Bartosz