Re: [PATCH v2 2/4] dmaengine: Add STM32 MDMA driver

From: Vinod Koul
Date: Wed Jul 26 2017 - 00:57:37 EST


On Mon, Jul 24, 2017 at 09:34:18AM +0000, Pierre Yves MORDRET wrote:
>
> On 07/21/2017 12:32 PM, Pierre Yves MORDRET wrote:
> >
> >
> > On 07/21/2017 11:54 AM, Vinod Koul wrote:
> >> On Fri, Jul 21, 2017 at 09:30:00AM +0000, Pierre Yves MORDRET wrote:
> >>>>> +static enum dma_slave_buswidth stm32_mdma_get_max_width(u32 buf_len, u32
> tlen)
> >>>>> +{
> >>>>> + enum dma_slave_buswidth max_width = DMA_SLAVE_BUSWIDTH_8_BYTES;
> >>>>> +
> >>>>> + while (((buf_len % max_width) || (tlen < max_width)) &&
> >>>>> + (max_width > DMA_SLAVE_BUSWIDTH_1_BYTE))
> >>>>> + max_width = max_width >> 1;
> >>>>
> >>>> ok, this is a bit hard to read...
> >>>
> >>> This code snippet has already been reworked and optimized. Would you mind to
> >>> provide me a example with your expectation ? Thanks
> >>
> >> Code is optimized yes, but readable no
> >>
> >> I would like readability to be improved upon...
> >>
> >
> > gotcha
> >
>
> Doest he code snippet below has a better looking for you ?
>
> for (max_width = DMA_SLAVE_BUSWIDTH_8_BYTES;
> max_width > DMA_SLAVE_BUSWIDTH_1_BYTE; max_width >>= 1)
> if (((buf_len % max_width) == 0) && (tlen >= max_width))
> break;

Am actually not sure :(

Indentation wise it is still a bit messy to follow..

How about:

for (max_width = DMA_SLAVE_BUSWIDTH_8_BYTES;
max_width > DMA_SLAVE_BUSWIDTH_1_BYTE;
max_width >>=1) {
if (((buf_len % max_width) == 0) && (tlen >= max_width))
break;
}

Thanks
--
~Vinod