[for-next][PATCH 00/12] tracing: Updates for 4.13

From: Steven Rostedt
Date: Thu Jun 15 2017 - 06:53:34 EST


git://git.kernel.org/pub/scm/linux/kernel/git/rostedt/linux-trace.git
for-next

Head SHA1: 681bec0367c2606b6154060310a2ffa543175980


Jeremy Linton (11):
trace: rename kernel enum section to eval
trace: rename trace_enum_map to trace_eval_map
trace: rename struct module entry for trace enums
trace: rename trace enum data structures in trace.c
trace: rename trace_enum_mutex to trace_eval_mutex
trace: rename trace.c enum functions
trace: rename enum_map functions
tracing: Rename enum_replace to eval_replace
tracing: define TRACE_DEFINE_SIZEOF() macro to map sizeof's to their values
tracing: Add TRACE_DEFINE_SIZEOF() macros
tracing: Rename update the enum_map file

Joel Fernandes (1):
tracing: Remove unused declaration of trace_stop_cmdline_recording

----
arch/arm64/kvm/trace.h | 2 +
include/asm-generic/vmlinux.lds.h | 6 +-
include/linux/module.h | 4 +-
include/linux/tracepoint.h | 7 +-
include/trace/events/xen.h | 13 ++-
include/trace/trace_events.h | 26 ++++-
kernel/module.c | 6 +-
kernel/trace/Kconfig | 22 ++---
kernel/trace/trace.c | 196 +++++++++++++++++++-------------------
kernel/trace/trace.h | 4 +-
kernel/trace/trace_events.c | 24 ++---
11 files changed, 168 insertions(+), 142 deletions(-)