Re: [PATCH 2/3] x86/numa_emulation: assign physnode_mask directly from numa_nodes_parsed

From: David Rientjes
Date: Mon Apr 10 2017 - 20:26:10 EST


On Tue, 11 Apr 2017, Wei Yang wrote:

> According to current code path, numa_nodes_parsed is already setup when
> numa_emucation() is called.
>
> x86_numa_init()
> numa_init()
> init_func()
>
> numa_emulation()
>
> numa_register_memblks()
>

s/numa_emucation/numa_emulation/, but I think everything above should just
be reworded to say the following since it establishes the dependency:

numa_init() has already called init_func(), which is responsible for
setting numa_nodes_parsed, so use this nodemask instead of re-finding it
when calling numa_emulation().

> This means we can get the physnode_mask directly from numa_nodes_parsed. At
> the same time, this patch correct the comment of these two functions.
>
> Signed-off-by: Wei Yang <richard.weiyang@xxxxxxxxx>

Acked-by: David Rientjes <rientjes@xxxxxxxxxx>