Re: [patch 3/3] x86/vdso: Sanitize vdso*_enabled handling

From: Andy Lutomirski
Date: Mon Apr 10 2017 - 11:56:13 EST


On Mon, Apr 10, 2017 at 8:14 AM, Thomas Gleixner <tglx@xxxxxxxxxxxxx> wrote:
> +static int vdso32_sysctl;
> +
> +static int vdso_update_handler(struct ctl_table *table, int write,
> + void __user *buffer, size_t *lenp,
> + loff_t *ppos)
> +{
> + int ret = proc_dointvec_minmax(table, write, buffer, lenp, ppos);

Using a global for the temporary is gross and mildly racy. I would
just open-code the conversion. Or, even better, add proc_dobool().

I'm not convinced that the current patch is a cleanup.

--Andy