Re: [PATCH 0/5 v2] tracing: Add usecase of synchronize_rcu_tasks() and stack_tracer_disable()

From: Steven Rostedt
Date: Fri Apr 07 2017 - 11:29:09 EST


On Fri, 7 Apr 2017 08:11:46 -0700
"Paul E. McKenney" <paulmck@xxxxxxxxxxxxxxxxxx> wrote:

> On Fri, Apr 07, 2017 at 10:58:26AM -0400, Steven Rostedt wrote:
> > On Fri, 7 Apr 2017 07:43:35 -0700
> > "Paul E. McKenney" <paulmck@xxxxxxxxxxxxxxxxxx> wrote:
> >
> > > On Fri, Apr 07, 2017 at 10:01:06AM -0400, Steven Rostedt wrote:
> > > > Paul,
> > > >
> > > > Here's my latest. You OK with it?
> > >
> > > Given your update to 3/5, I suspect that we could live with it. I am
> > > expecting some complaints about increases in idle-entry latency, but might
> > > be best to wait for complaints rather than complexifying too proactively.
> >
> > We only added a this_cpu_inc() and this_cpu_dec() which are very fast
> > operations. I highly doubt it will be measurable. Although, I'm talking
> > about x86, IIRC, the this_cpu_inc/dec were be poorly written for other
> > archs in the past. I'm not sure if that was fixed though.
>
> That is an issue for CPUs that don't have a to-memory increment
> instruction. How about __this_cpu_inc() and __this_cpu_dec(), given
> that preemption is disabled?

Ah, so the issue still exists. I remember complaining to Christoph
Lamater about this. Yeah, switching to __this_cpu_inc() works as well.


>
> > > That said, there isn't supposed to be any tracing during the now very
> > > small interval where RCU's idle-entry is incomplete. Mightn't it be
> > > better to (under CONFIG_PROVE_RCU or some such) give splats if tracing
> > > showed up in that interval?
> >
> > Again, tracing is not the issue. I do function tracing in that location
> > without any problems. The issue here was the stack tracer.
> >
> > Maybe we can create a new variable that is more cache local to the RCU
> > code.
> >
> > What about calling it "rcu_disabled"? Then tracing that depends on RCU
> > can simply check that.
> >
> > s/stack_trace_disable/disable_rcu/
> > s/stack_trace_enable/enable_rcu/
> >
> > export a per cpu variable rcu_disabled
> >
> > Then I can have the stack tracer check that variable as well. And we
> > could even put in a WARN_ON(this_cpu_read(rcu_disabled) in the
> > TRACE_EVENT() macros.
> >
> > Thoughts?
>
> At this point, if you can use the "__" versions, the change should be
> small. With that change, if no one else complains, I am OK.

Yeah, I was thinking this_cpu_inc() was the same as __this_cpu_inc(),
(where I simply forgot about the existence of __this_cpu_inc()
otherwise I would have used it from the beginning.

But that said, I wonder if a rcu_disabled would make more sense.
I kinda feel we are currently doing this backwards. The real state
change is that rcu is currently doing something that will definitely
break any rcu_irq_enter() call. Anything doing that to wake up RCU
should be informed that that doesn't currently work. Having a way for
RCU to tell others that "rcu_irq_enter() wont do anything right now"
seems more appropriate to me, as we can then do checks in the
trace_event_rcuidle() code to do the same thing.

Having RCU just pick stack tracing seems to be backward to me.

-- Steve