Re: [PATCH 3/5 v2] tracing: Add stack_tracer_disable/enable() functions

From: Steven Rostedt
Date: Fri Apr 07 2017 - 10:22:42 EST


On Fri, 07 Apr 2017 10:01:09 -0400
Steven Rostedt <rostedt@xxxxxxxxxxx> wrote:

> diff --git a/include/linux/ftrace.h b/include/linux/ftrace.h
> index ef7123219f14..40afee35565a 100644
> --- a/include/linux/ftrace.h
> +++ b/include/linux/ftrace.h
> @@ -286,6 +286,12 @@ int
> stack_trace_sysctl(struct ctl_table *table, int write,
> void __user *buffer, size_t *lenp,
> loff_t *ppos);
> +
> +void stack_tracer_disable(void);
> +void stack_tracer_enable(void);
> +#else
> +static inline void stack_tracer_disable(void) { }
> +static inline void stack_tracer_enabe(void) { }

Grumble. kbot caught that this is enabe not enable.

I cut and pasted the bad name to all places, and when I compiled, it
complained. I fixed the ones to make my system build, but forgot to fix
the #ifndef version :-(

I'll fix this before pushing.

-- Steve