Re: [Outreachy kernel] [PATCH 4/4] iio: light: si1145: Replace ternary operator with min macro

From: Lars-Peter Clausen
Date: Wed Mar 29 2017 - 08:53:22 EST


On 03/29/2017 02:40 PM, Julia Lawall wrote:
>
>
> On Wed, 29 Mar 2017, simran singhal wrote:
>
>> Use macro min() to get the minimum of two values for brevity and
>> readability.
>>
>> Signed-off-by: simran singhal <singhalsimran0@xxxxxxxxx>
>> ---
>> drivers/iio/light/si1145.c | 2 +-
>> 1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/drivers/iio/light/si1145.c b/drivers/iio/light/si1145.c
>> index 096034c..e7ad6fb 100644
>> --- a/drivers/iio/light/si1145.c
>> +++ b/drivers/iio/light/si1145.c
>> @@ -557,7 +557,7 @@ static int si1145_set_chlist(struct iio_dev *indio_dev, unsigned long scan_mask)
>> data->scan_mask = scan_mask;
>> ret = si1145_param_set(data, SI1145_PARAM_CHLIST, reg);
>>
>> - return ret < 0 ? ret : 0;
>> + return min(ret, 0);
>
> A similar change involving max was already rejected. ret < 0 is a
> standard way of detecting an error, so perhaps leaving that explicitly
> present will be preferred.

I think a more sensible thing to do here is to check whether ret/err can
actually take any positive values and if not, replace the whole thing with
just 'return ret;' or 'return some_fn()'. I'd expect that his can be done in
most of the cases.