[PATCH] netfilter: ipset: Use max macro instead of ternary operator

From: simran singhal
Date: Tue Mar 28 2017 - 09:33:33 EST


This patch replaces ternary operator with macro max as it shorter and
thus increases code readability. Macro max return the maximum of the two
compared values.

Signed-off-by: simran singhal <singhalsimran0@xxxxxxxxx>
---
net/netfilter/ipset/ip_set_core.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/net/netfilter/ipset/ip_set_core.c b/net/netfilter/ipset/ip_set_core.c
index 10a3694..248fef7 100644
--- a/net/netfilter/ipset/ip_set_core.c
+++ b/net/netfilter/ipset/ip_set_core.c
@@ -571,7 +571,7 @@ ip_set_test(ip_set_id_t index, const struct sk_buff *skb,
}

/* Convert error codes to nomatch */
- return (ret < 0 ? 0 : ret);
+ return max(0, ret);
}
EXPORT_SYMBOL_GPL(ip_set_test);

--
2.7.4