[tip:x86/urgent] x86/boot: Correct setup_header.start_sys name

From: tip-bot for Borislav Petkov
Date: Wed Mar 01 2017 - 05:43:20 EST


Commit-ID: 8392f16d38bb5222c03073a3906b7fd272386faf
Gitweb: http://git.kernel.org/tip/8392f16d38bb5222c03073a3906b7fd272386faf
Author: Borislav Petkov <bp@xxxxxxx>
AuthorDate: Tue, 21 Feb 2017 19:36:39 +0100
Committer: Thomas Gleixner <tglx@xxxxxxxxxxxxx>
CommitDate: Wed, 1 Mar 2017 11:27:26 +0100

x86/boot: Correct setup_header.start_sys name

It is called start_sys_seg elsewhere so rename it to that. It is an
obsolete field so we could just as well directly call it __u16 __pad...

No functional change.

Signed-off-by: Borislav Petkov <bp@xxxxxxx>
Link: http://lkml.kernel.org/r/20170221183639.16554-1-bp@xxxxxxxxx
Signed-off-by: Thomas Gleixner <tglx@xxxxxxxxxxxxx>

---
arch/x86/include/uapi/asm/bootparam.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/arch/x86/include/uapi/asm/bootparam.h b/arch/x86/include/uapi/asm/bootparam.h
index 5138dac..07244ea 100644
--- a/arch/x86/include/uapi/asm/bootparam.h
+++ b/arch/x86/include/uapi/asm/bootparam.h
@@ -58,7 +58,7 @@ struct setup_header {
__u32 header;
__u16 version;
__u32 realmode_swtch;
- __u16 start_sys;
+ __u16 start_sys_seg;
__u16 kernel_version;
__u8 type_of_loader;
__u8 loadflags;