Re: [PATCH trivial 2/4] rtlwifi: rtl8821ae: Spelling s/wrtie_addr/write_addr/

From: Larry Finger
Date: Fri Feb 17 2017 - 11:14:50 EST


On 02/17/2017 09:36 AM, Geert Uytterhoeven wrote:
As per symmetry with _rtl8821ae_dbi_read(), "wrtie" is not a funky
register acronym, but a simple misspelling of "write".

Signed-off-by: Geert Uytterhoeven <geert+renesas@xxxxxxxxx>
Cc: Larry Finger <Larry.Finger@xxxxxxxxxxxx>
Cc: Chaoming Li <chaoming_li@xxxxxxxxxxxxxx>
Cc: netdev@xxxxxxxxxxxxxxx

I'm not sure that it is possible to have a typo in a variable name. That seems to be within an author's prerogative. Nonetheless, the patch is OK other than it was sent to the wrong destination. Patches for this driver should go through linux-wireless@xxxxxxxxxxxxxxxx Kalle Valo is the wireless maintainer, but it is not necessary to send to him directly as he usually picks up the patches from Patchwork.

Larry

---
drivers/net/wireless/realtek/rtlwifi/rtl8821ae/hw.c | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/drivers/net/wireless/realtek/rtlwifi/rtl8821ae/hw.c b/drivers/net/wireless/realtek/rtlwifi/rtl8821ae/hw.c
index 4f83eee1ff75bc81..546f085afb8f42fa 100644
--- a/drivers/net/wireless/realtek/rtlwifi/rtl8821ae/hw.c
+++ b/drivers/net/wireless/realtek/rtlwifi/rtl8821ae/hw.c
@@ -1135,13 +1135,13 @@ static u8 _rtl8821ae_dbi_read(struct rtl_priv *rtlpriv, u16 addr)
static void _rtl8821ae_dbi_write(struct rtl_priv *rtlpriv, u16 addr, u8 data)
{
u8 tmp = 0, count = 0;
- u16 wrtie_addr, remainder = addr % 4;
+ u16 write_addr, remainder = addr % 4;

- wrtie_addr = REG_DBI_WDATA + remainder;
- rtl_write_byte(rtlpriv, wrtie_addr, data);
+ write_addr = REG_DBI_WDATA + remainder;
+ rtl_write_byte(rtlpriv, write_addr, data);

- wrtie_addr = (addr & 0xfffc) | (BIT(0) << (remainder + 12));
- rtl_write_word(rtlpriv, REG_DBI_ADDR, wrtie_addr);
+ write_addr = (addr & 0xfffc) | (BIT(0) << (remainder + 12));
+ rtl_write_word(rtlpriv, REG_DBI_ADDR, write_addr);

rtl_write_byte(rtlpriv, REG_DBI_FLAG, 0x1);