Re: [PATCH] x86/apic: Fix two typos in comments

From: Ingo Molnar
Date: Thu Jan 05 2017 - 03:19:08 EST



* Dou Liyang <douly.fnst@xxxxxxxxxxxxxx> wrote:

> s/inr_logical_cpuidi/nr_logical_cpuids/
> s/generic_processor_info()/__generic_processor_info()/
>
> Signed-off-by: Dou Liyang <douly.fnst@xxxxxxxxxxxxxx>
> ---
> arch/x86/kernel/apic/apic.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/arch/x86/kernel/apic/apic.c b/arch/x86/kernel/apic/apic.c
> index 5b7e43e..c32a3ad 100644
> --- a/arch/x86/kernel/apic/apic.c
> +++ b/arch/x86/kernel/apic/apic.c
> @@ -2028,7 +2028,7 @@ void disconnect_bsp_APIC(int virt_wire_setup)
> /*
> * The number of allocated logical CPU IDs. Since logical CPU IDs are allocated
> * contiguously, it equals to current allocated max logical CPU ID plus 1.
> - * All allocated CPU ID should be in [0, nr_logical_cpuidi), so the maximum of
> + * All allocated CPU ID should be in [0, nr_logical_cpuids), so the maximum of

There's another typo in that sentence as well, and the wording should be clarified
as well while at it. Something like this would work for me:

> + * All allocated CPU IDs should be in the [0, nr_logical_cpuids) range,
> + * so the maximum of

Thanks,

Ingo