Re: [PATCH] vt: fix Scroll Lock LED trigger name

From: Pavel Machek
Date: Mon Dec 05 2016 - 08:48:50 EST


Hi!

> There is a disagreement between drivers/tty/vt/keyboard.c and
> drivers/input/input-leds.c with regard to what is a Scroll Lock LED
> trigger name: input calls it "kbd-scrolllock", but vt calls it
> "kbd-scrollock" (two l's).
> This prevents Scroll Lock LED trigger from binding to this LED by default.
>
> Since it is a scroLL Lock LED, this interface was introduced only about a
> year ago and in an Internet search people seem to reference this trigger
> only to set it to this LED let's simply rename it to "kbd-scrolllock".
>
> Also, it looks like this was supposed to be changed before this code was
> merged: https://lkml.org/lkml/2015/6/9/697 but it was done only on
> the input side.
>
> Signed-off-by: Maciej S. Szmigiero <mail@xxxxxxxxxxxxxxxxxxxxx>
> ---
> drivers/tty/vt/keyboard.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/tty/vt/keyboard.c b/drivers/tty/vt/keyboard.c
> index d5d81d4d3c04..3dd6a491cdba 100644
> --- a/drivers/tty/vt/keyboard.c
> +++ b/drivers/tty/vt/keyboard.c
> @@ -982,7 +982,7 @@ static void kbd_led_trigger_activate(struct led_classdev *cdev)
> KBD_LED_TRIGGER((_led_bit) + 8, _name)
>
> static struct kbd_led_trigger kbd_led_triggers[] = {
> - KBD_LED_TRIGGER(VC_SCROLLOCK, "kbd-scrollock"),
> + KBD_LED_TRIGGER(VC_SCROLLOCK, "kbd-scrolllock"),

Would it be feasible to rename "VC_SCROLLOCK" to "VC_SCROLLLOCK", too?

--
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html

Attachment: signature.asc
Description: Digital signature