Re: [PATCH 1/2] fs: use mapping_set_error instead of opencoded set_bit

From: Andrew Morton
Date: Tue Sep 13 2016 - 17:32:10 EST


On Tue, 13 Sep 2016 08:53:01 +0200 Michal Hocko <mhocko@xxxxxxxxxx> wrote:

> On Mon 12-09-16 15:18:23, Andrew Morton wrote:
> > On Mon, 12 Sep 2016 15:11:46 -0700 Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> wrote:
> >
> > > > @@ -409,7 +408,7 @@ static int afs_write_back_from_locked_page(struct afs_writeback *wb,
> > > > case -ENOMEDIUM:
> > > > case -ENXIO:
> > > > afs_kill_pages(wb->vnode, true, first, last);
> > > > - set_bit(AS_EIO, &wb->vnode->vfs_inode.i_mapping->flags);
> > > > + mapping_set_error(wb->vnode->vfs_inode.i_mapping, -ENXIO);
> > >
> > > This one is a functional change: mapping_set_error() will rewrite
> > > -ENXIO into -EIO. Doesn't seem at all important though.
> >
> > hm, OK, it's not a functional change - the code was already doing
> > s/ENXIO/EIO/.
>
> Yes the rewrite is silent but I've decided to keep the current errno
> because I have no idea whether this can change in future. It doesn't
> sound probable but it also sounds safer to do an overwrite at a single
> place rather than all over the place /me thinks.

Well, this is the only place in the kernel where we attempt to set
anything other than EIO. I do think it's better to be honest about
what's happening, right here at the callsite.