Re: [PATCH 03/47] block-rbd: Adjust the position of a jump label in rbd_header_from_disk()

From: Ilya Dryomov
Date: Tue Sep 13 2016 - 04:01:25 EST


On Mon, Sep 12, 2016 at 8:44 PM, SF Markus Elfring
<elfring@xxxxxxxxxxxxxxxxxxxxx> wrote:
> From: Markus Elfring <elfring@xxxxxxxxxxxxxxxxxxxxx>
> Date: Sun, 11 Sep 2016 13:37:34 +0200
>
> Add a space character before a single jump label in this function
> according to the current Linux coding style convention.
>
> Signed-off-by: Markus Elfring <elfring@xxxxxxxxxxxxxxxxxxxxx>
> ---
> drivers/block/rbd.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/block/rbd.c b/drivers/block/rbd.c
> index f4212e1..d61a066 100644
> --- a/drivers/block/rbd.c
> +++ b/drivers/block/rbd.c
> @@ -1064,7 +1064,7 @@ static int rbd_header_from_disk(struct rbd_device *rbd_dev,
> header->snap_sizes = snap_sizes;
>
> return 0;
> -out_2big:
> + out_2big:
> ret = -EIO;
> kfree(snap_sizes);
> free_names:
> --
> 2.10.0
>

Can you point where this current convention is documented? Certainly
not in CodingStyle, AFAICT...

I know some people prefer a single space in there because it makes
"diff -p" work better, but nowadays with "git diff" this argument is
pretty moot.

Thanks,

Ilya