Re: [Outreachy kernel] [PATCH] Staging: rtl8188eu: Remove ternary operator

From: Bhumika Goyal
Date: Mon Sep 12 2016 - 12:52:04 EST


On Mon, Sep 12, 2016 at 8:14 PM, Jes Sorensen <jes.sorensen@xxxxxxxxx> wrote:
> On 09/12/16 09:58, Bhumika Goyal wrote:
>> Relational and logical operators evaluate to either true or false.
>> Explicit conversion is not needed so remove the ternary operator.
>> Done using coccinelle:
>>
>> @r@
>> expression A,B;
>> symbol true,false;
>> binary operator b = {==,!=,&&,||,>=,<=,>,<};
>> @@
>> - (A b B) ? true : false
>> + A b B
>>
>> Signed-off-by: Bhumika Goyal <bhumirks@xxxxxxxxx>
>> ---
>> drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 8 ++++----
>> drivers/staging/rtl8188eu/hal/phy.c | 2 +-
>> drivers/staging/rtl8188eu/hal/rtl8188e_dm.c | 3 ++-
>> 3 files changed, 7 insertions(+), 6 deletions(-)
>>
>> diff --git a/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c b/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c
>> index 9544e55..b43f57be 100644
>> --- a/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c
>> +++ b/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c
>> @@ -705,7 +705,7 @@ static int issue_probereq_ex(struct adapter *padapter,
>> unsigned long start = jiffies;
>>
>> do {
>> - ret = issue_probereq(padapter, pssid, da, wait_ms > 0 ? true : false);
>> + ret = issue_probereq(padapter, pssid, da, wait_ms > 0);
>>
>> i++;
>>
>> @@ -1293,7 +1293,7 @@ int issue_nulldata(struct adapter *padapter, unsigned char *da, unsigned int pow
>> da = pnetwork->MacAddress;
>>
>> do {
>> - ret = _issue_nulldata(padapter, da, power_mode, wait_ms > 0 ? true : false);
>> + ret = _issue_nulldata(padapter, da, power_mode, wait_ms > 0);
>>
>> i++;
>>
>> @@ -1420,7 +1420,7 @@ int issue_qos_nulldata(struct adapter *padapter, unsigned char *da, u16 tid, int
>> da = pnetwork->MacAddress;
>>
>> do {
>> - ret = _issue_qos_nulldata(padapter, da, tid, wait_ms > 0 ? true : false);
>> + ret = _issue_qos_nulldata(padapter, da, tid, wait_ms > 0);
>>
>> i++;
>>
>> @@ -1527,7 +1527,7 @@ static int issue_deauth_ex(struct adapter *padapter, u8 *da,
>> unsigned long start = jiffies;
>>
>> do {
>> - ret = _issue_deauth(padapter, da, reason, wait_ms > 0 ? true : false);
>> + ret = _issue_deauth(padapter, da, reason, wait_ms > 0);
>>
>> i++;
>
> While this part of the patch is technically correct, I would argue it
> doesn't improve the code. It would make the code more readable to pass
> in the wait_ms value and then have the decision made based on that in
> the called function.
>

Ok, I will keep the wait_ms ternary operation as it is and send a v2.
Thanks for the input.

Thanks,
Bhumika

> Cheers,
> Jes
>