Re: [RFC][PATCH 1/3] locking/mutex: Rework mutex::owner

From: Tim Chen
Date: Tue Aug 23 2016 - 16:52:51 EST


On Tue, 2016-08-23 at 15:55 -0400, Waiman Long wrote:
> On 08/23/2016 08:46 AM, Peter Zijlstra wrote:
>
> I have 2 more comments about the code.
> 1) There are a couple of places where you only use 0x3 in mutex.c. TheyÂ
> should be replaced by the symbolic name instead.

May be easier to read if (owner & 0x3) and
(owner & ~0x3) are changed to something likeÂ
_owner_flag(owner) and _owner_task(owner).

Tim

> 2) We should make __mutex_lock_slowpath() a noinline function just likeÂ
> __mutex_lock_killable_slowpath() or __mutex_lock_interruptible_slowpath().
>
> Cheers,
> Longman