Re: [PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking for built-in or module

From: Felipe Balbi
Date: Thu Aug 18 2016 - 09:46:39 EST



Hi,

Javier Martinez Canillas <javier@xxxxxxxxxxxxxxx> writes:
> The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either
> built-in or as a module, use that macro instead of open coding the same.
>
> Using the macro makes the code more readable by helping abstract away some
> of the Kconfig built-in and module enable details.
>
> Signed-off-by: Javier Martinez Canillas <javier@xxxxxxxxxxxxxxx>

Assuming this is going through trivial tree:

Acked-by: Felipe Balbi <felipe.balbi@xxxxxxxxxxxxxxx>

thanks

> ---
>
> drivers/usb/serial/keyspan_pda.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/usb/serial/keyspan_pda.c b/drivers/usb/serial/keyspan_pda.c
> index 4f7e072e4e00..e49ad0c63ad8 100644
> --- a/drivers/usb/serial/keyspan_pda.c
> +++ b/drivers/usb/serial/keyspan_pda.c
> @@ -30,12 +30,12 @@
> #include <linux/usb/ezusb.h>
>
> /* make a simple define to handle if we are compiling keyspan_pda or xircom support */
> -#if defined(CONFIG_USB_SERIAL_KEYSPAN_PDA) || defined(CONFIG_USB_SERIAL_KEYSPAN_PDA_MODULE)
> +#if IS_ENABLED(CONFIG_USB_SERIAL_KEYSPAN_PDA)
> #define KEYSPAN
> #else
> #undef KEYSPAN
> #endif
> -#if defined(CONFIG_USB_SERIAL_XIRCOM) || defined(CONFIG_USB_SERIAL_XIRCOM_MODULE)
> +#if IS_ENABLED(CONFIG_USB_SERIAL_XIRCOM)
> #define XIRCOM
> #else
> #undef XIRCOM
> --
> 2.5.5
>
> --
> To unsubscribe from this list: send the line "unsubscribe linux-usb" in
> the body of a message to majordomo@xxxxxxxxxxxxxxx
> More majordomo info at http://vger.kernel.org/majordomo-info.html

--
balbi

Attachment: signature.asc
Description: PGP signature