Re: [PATCH] backlight-tosa: Delete owner assignment

From: Lee Jones
Date: Mon Aug 15 2016 - 09:44:46 EST


On Mon, 15 Aug 2016, Vegard Nossum wrote:

> On 15 August 2016 at 13:12, SF Markus Elfring
> <elfring@xxxxxxxxxxxxxxxxxxxxx> wrote:
> > From: Markus Elfring <elfring@xxxxxxxxxxxxxxxxxxxxx>
> > Date: Mon, 15 Aug 2016 13:03:29 +0200
> >
> > The field "owner" is set by core. Thus delete an extra initialisation.
>
> Hi,
>
> Just a small nit on the patch title: "delete owner assignment" is
> virtually useless as a title because it has no meaning without the
> broader context and only describes the literal change. It's like
> naming a patch "add a line" or "change the code"; it serves no
> purpose.
>
> How about "backlight-tosa: delete _unnecessary_ assignment"? This
> immediately communicates the reason for/intent of the patch (there is
> unnecessary code, thus we can simplify it).

backlight-tosa: Do not manually assign THIS_MODULE to .owner

This is unnecessary because ...

> (Sorry about singling out this patch and the apparent bikeshedding,
> this comment obviously applies to a lot of patches by a lot of
> authors!)
>
> Thanks,
>
>
> Vegard

--
Lee Jones
Linaro STMicroelectronics Landing Team Lead
Linaro.org â Open source software for ARM SoCs
Follow Linaro: Facebook | Twitter | Blog