Re: [PATCH v3 0/7] x86: Rewrite switch_to()

From: Brian Gerst
Date: Sun Aug 14 2016 - 06:27:42 EST


On Sat, Aug 13, 2016 at 1:16 PM, Linus Torvalds
<torvalds@xxxxxxxxxxxxxxxxxxxx> wrote:
> On Sat, Aug 13, 2016 at 9:38 AM, Brian Gerst <brgerst@xxxxxxxxx> wrote:
>> This patch set simplifies the switch_to() code, by moving the stack switch
>> code out of line into an asm stub before calling __switch_to(). This ends
>> up being more readable, and using the C calling convention instead of
>> clobbering all registers improves code generation. It also allows newly
>> forked processes to construct a special stack frame to seamlessly flow
>> to ret_from_fork, instead of using a test and branch, or an unbalanced
>> call/ret.
>
> Do you have performance numbers? Is it noticeable/measurable?

How do I measure it? The perf documentation isn't easy to understand.

It shouldn't be a significant change. On a 64-bit defconfig build,
__schedule() shrinks by 103 bytes. It's hard to analyse what exactly
changes, but it's likely that GCC can allocate registers better
without all the clobbers of the old inline asm version interfering.
The new stub adds just 39 bytes.

--
Brian Gerst