[PATCH 0075/1285] Replace numeric parameter like 0444 with macro

From: Baole Ni
Date: Tue Aug 02 2016 - 14:32:11 EST


I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.

Signed-off-by: Chuansheng Liu <chuansheng.liu@xxxxxxxxx>
Signed-off-by: Baole Ni <baolex.ni@xxxxxxxxx>
---
drivers/base/firmware_class.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/base/firmware_class.c b/drivers/base/firmware_class.c
index 773fc30..7bcf099 100644
--- a/drivers/base/firmware_class.c
+++ b/drivers/base/firmware_class.c
@@ -289,7 +289,7 @@ static const char * const fw_path[] = {
* from kernel command line because firmware_class is generally built in
* kernel instead of module.
*/
-module_param_string(path, fw_path_para, sizeof(fw_path_para), 0644);
+module_param_string(path, fw_path_para, sizeof(fw_path_para), S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
MODULE_PARM_DESC(path, "customized firmware image search path with a higher priority than default path");

static void fw_finish_direct_load(struct device *device,
@@ -689,7 +689,7 @@ out:
return written;
}

-static DEVICE_ATTR(loading, 0644, firmware_loading_show, firmware_loading_store);
+static DEVICE_ATTR(loading, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH, firmware_loading_show, firmware_loading_store);

static ssize_t firmware_data_read(struct file *filp, struct kobject *kobj,
struct bin_attribute *bin_attr,
--
2.9.2