Re: [PATCH v2 1/8] mm/zsmalloc: modify zs compact trace interface

From: Minchan Kim
Date: Tue Jul 05 2016 - 22:31:54 EST


Hi Ganesh,

On Mon, Jul 04, 2016 at 02:49:52PM +0800, Ganesh Mahendran wrote:
> This patch changes trace_zsmalloc_compact_start[end] to
> trace_zs_compact_start[end] to keep function naming consistent
> with others in zsmalloc
>
> Also this patch remove pages_total_compacted information which
> may not really needed.
>
> Signed-off-by: Ganesh Mahendran <opensource.ganesh@xxxxxxxxx>

Once we decide to add event trace, I prefer getting more detailed
information which is hard to get it via /sys/block/zram/.
So, we can add trace __zs_compact as well as zs_compact with
some changes.

IOW,

zs_compact
trace_zs_compact_start(pool->name)
__zs_compact
trace_zs_compact(class, scanned_obj, freed_pages)
trace_zs_compact_end(pool->name)