[PATCH 6/6] x86, KASLR: Rename "random" to "random_addr"

From: Kees Cook
Date: Mon Apr 18 2016 - 12:43:10 EST


The variable "random" is also the name of a libc function. It's better
coding style to avoid overloading such things, so rename it to the more
accurate "random_addr".

Suggested-by: Ingo Molnar <mingo@xxxxxxxxxx>
Signed-off-by: Kees Cook <keescook@xxxxxxxxxxxx>
---
arch/x86/boot/compressed/kaslr.c | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/arch/x86/boot/compressed/kaslr.c b/arch/x86/boot/compressed/kaslr.c
index 9e03190d00ad..9c29e7885ef0 100644
--- a/arch/x86/boot/compressed/kaslr.c
+++ b/arch/x86/boot/compressed/kaslr.c
@@ -312,7 +312,7 @@ unsigned char *choose_random_location(unsigned char *input,
unsigned long output_size)
{
unsigned long choice = (unsigned long)output;
- unsigned long random;
+ unsigned long random_addr;

#ifdef CONFIG_HIBERNATION
if (!cmdline_find_option_bool("kaslr")) {
@@ -333,17 +333,17 @@ unsigned char *choose_random_location(unsigned char *input,
(unsigned long)output, output_size);

/* Walk e820 and find a random address. */
- random = find_random_addr(choice, output_size);
- if (!random) {
+ random_addr = find_random_addr(choice, output_size);
+ if (!random_addr) {
debug_putstr("KASLR could not find suitable E820 region...\n");
goto out;
}

/* Always enforce the minimum. */
- if (random < choice)
+ if (random_addr < choice)
goto out;

- choice = random;
+ choice = random_addr;
out:
return (unsigned char *)choice;
}
--
2.6.3